Das Taskplane-Objekt Fehler

Dieses Thema im Forum "System" wurde erstellt von Bisut, 8. Juni 2020.

  1. Bisut

    Bisut Mitglied

    Guten Tag,

    bekommen verstärkt in der Sage 8.1 Fehler bei der Anmeldungen. Nicht jeder, sondern wahrscheinlich die User mit Windows 10. Aktuell bei dem dieser Fehler vorkommt:
    PC: Windows 10 64bit v1909 aktuelle Windows-Updates, Office 2016 32bit

    Interner Fehler: Das Taskplane-Objekt der Anwendung ist ungültig

    Die Sage startet nicht mehr!
     

    Anhänge:

  2. m.becker

    m.becker ESC GmbH Mitglieder

  3. Bisut

    Bisut Mitglied

    Wir haben bei dem einen Kunden das tatsächlich lösen können mittels des Sage Vorschlages. :)

    Bei dem anderen Kunden bringt der Link leider keinen Erfolg. :( Da ist die Hilfe von Sage auch oft machtlos und bietet hier keine gute Lösungen. Dort werden wir jetzt wie bei den meisten anderen Kunden auch, die komplette Deinstallation und Bereinigungen der Sage vornehmen und zusätzlich die komplette Deinstallation des MS Office Paketes mit MS Tool Bereinigungen. Das scheint zumindest immer zu helfen, auch wenn dieser Aufwand 2 bis 3 Stunden am PC bedeuten und es für den Kunden super ärgerlich ist. Ist immer nur wieder nervig auf solche Probleme zu stoßen. Scheint immer irgendwie nur Sage zu betreffen, während andere Hersteller das umgehen können.
     
  4. m.becker

    m.becker ESC GmbH Mitglieder

    Bei unseren Kunden lag es bisher fast immer daran, dass nach Windows-Updates plötzlich Berechtigungen auf die "Microsoft.Office.Interop.Access.dll" und/oder "OFFICE.DLL" fehlten. Ich habe dafür eine Batch-Datei erstellt, die der Kunde (mit Admin-Rechten) selbst ausführen kann, um die Berechtigungen zu korrigieren. Seitdem gab es keine Probleme mehr.
     
  5. Bisut

    Bisut Mitglied

    @m.becker = wäre nett, das Batch mir zu geben, dann könnte ich vielleicht heute schon austesten. Danke sehr!
     
  6. m.becker

    m.becker ESC GmbH Mitglieder

    Hier die Datei für die Version 8.0, ohne Gewähr und Durchführung auf eigene Verantwortung.

    DLL-Pfade und Registry-Einträge müssen ggf. je nach Kundensystem angepasst werden. Das ganze ist relativ einfach gehalten. Für Kunden, die bei den Berechtigungen spezielle Anforderungen haben, müsste hier entsprechend verfeinert werden.
     

    Anhänge:

    d.schmitt und breithecker gefällt das.
  7. Bisut

    Bisut Mitglied

    Hat bei mir funktioniert. Danke!
     
  8. Bisut

    Bisut Mitglied

    @m.becker = Moin, die Reparatur (DLL setzen) funktioniert soweit. Aber leider kommt der Fehler wohl immer wieder. Zumindest bei meinem Kunden, so das ich das jedesmal neu setzen muss, dann funktioniert es wieder. Hat irgendwie mit Windows Updates oder MS Office Updates zu tun? Eine Idee, warum das so ist? Mit dem Tool von Ihnen ist das ja keine großartige Sache das neu auszuführen, aber lästig, weil Kunde das in der Regel nicht selber machen kann, da zumindest bei meinem Kunden, die User keine lokaler Admin Rechte besitzen.
     
  9. m.becker

    m.becker ESC GmbH Mitglieder

    Da es Office-Dateien betrifft, gehe ich davon aus, dass das Problem durch Windows Update verursacht wird. Vielleicht kann man die Batch über den Windows Aufgabenplaner regelmäßig mit Admin-Rechten automatisch laufen lassen. So bekommt man in Zukunft halt nicht mit, wenn das Problem irgendwann mal behoben wurde.
     
  10. mandreck

    mandreck Aktives Mitglied

    Dann starte die Datei doch über den Aufgabenplaner mit den Administrativen Rechten und machst dem Anwender eine Verknüpfung auf den Desktop die dieser nur anklicken muss wenn mal wieder etwas nicht so tut. Über den Planer sieht er ja nur die Verknüpfung zum Planer und nicht das Passwort des Admins.

    Gruß

    PS: @m.becker hatte ja auch geschrieben, das für die Berechtigungen das Script eventuell verfeinert werden muss.
     
  11. Bisut

    Bisut Mitglied

    Eigentlich eine Gute Idee, hat auch sofort funktioniert., aber schon am nächsten Tag wieder das Problem. Kunde muss jeden Tag mittlerweile das ausführen, damit er Sage arbeiten kann. Irgendwie nervt das und Sage scheint das Problem auszuhalten. Schön ist was anders. Bei einigen meiner Kunden funktioniert es sofort. Skript einmal ausführen und läuft. Bei diesen Kunden ist das schon super nervig. Ein Neu aufsetzen mit sämtlichen Bereinigen auch MS Office brachte bei dem PC auch nichts. Weiß nicht, aber anscheinend ist Sage nicht in der Lage das in den Griff zu bekommen.
     
  12. m.becker

    m.becker ESC GmbH Mitglieder

    Das ist ein Problem der Office-DLLs. Microsoft entfernt auf manchen Clients auf die beiden Dateien die Berechtigungen bzw. macht sie kaputt. Ich bin mir nicht sicher, ob Sage daran überhaupt etwas ändern könnte.

    Bei dem Kunden, der das Problem jeden Tag hat, muss mit den Windows Updates doch irgendwas nicht korrekt zu funktionieren. Scheinbar wird das problematische Update dann ja jeden Tag neu installiert.
     
  13. Bisut

    Bisut Mitglied

    Ich habe dort den Admin aktiviert, der hat alle Windows Upates (also wo der Fehler das erste mal auftrat) bereinigt, anschließend war der Fehler ja wieder da, obwohl keine Updates liefen. Daher dann die Bereinigung durchgeführt, was dann ein paar Tage gut ging, ja dann kamen natürlich wieder neue Updates (die sind aber bei allen anderen PC gleich); nur dieser PC macht dann diese Sorgen.

    Der Admin heute beschlossen, diesen User mit in die "Lokale Admin Rechte" aufzunehmen. Windows Updates sind seit ein paar Tagen gar nicht mehr gelaufen, der Fehler kam dann aber dennoch jeden Tag. Mit dem Skript war es bisher möglich das dann schnell weiter gearbeitet werden kann. Mal sehen, wie sich das Verhalten mit den lokalen Admin Rechten nun verhält. Bin gespannt wie es die Tage dann dort geht.

    Und ich denke schon, das Sage was machen könnte!

    ... Es gibt glaube ich kein anderes Produkt was so anfällig auf Windows reagiert...

    Sei es nur das Starten der Dienste (ständig Probleme) als auch diese Problem. Welches mich ja schon seit Jahren verfolgt. Ist ja nicht das erste mal das ich diesen Fehler oder ähnliches bekam.

    Dank dem Skript ist es jetzt natürlich super einfacher geworden, die Sage dazu zu bewegen zu starten. Ich denke, das Sage nicht mal diese DLL wirklich braucht.
     
  14. mandreck

    mandreck Aktives Mitglied

    @m.becker , es gab in letzter Zeit für Windows 10 Clients mit Office 2013 noch einige Sicherheitsupdates. Diese betreffen aber eigentlich nicht die Access Runtime 2013. Falls der Anwender eine andere Office Version verwendet und nur die Access Runtime von Sage sollen diese Probleme eigentlich nicht auftauchen..

    @Bisut , erhält der PC den überhaupt Windows Updates die Office 2013 betreffen? Schau bitte mal in den Updateverlauf. Prüfe beim Kunden ebenfalls noch ob er legale Versionen von Office 2013 im Einsatz hat, es gibt Tools die tauschen zwei spezielle DLLs aus um dem System vorzugauckeln das es legale Aktivierungen sind. Diese Lücke hat MS aber seit geraumer Zeit geschlossen. Natürlich bekommst Du das System durch Neuregistrierung wieder ans laufen, aber bei der nächsten Updateprüfung sind die wieder weg. Versuche mal nach der Neuregistrierung den Updatedienst für 7 Tage auszusetzen und prüfe ob das Verhalten weiter besteht oder nicht mehr. Wenn nicht mehr, weißt Du Bescheid was Sache ist. Dann hat der Kunde nicht mehr genügend Geld übrig wegen anderer teurer Software um sich legale Office Versionen anzuschaffen. :)
     
  15. Bisut

    Bisut Mitglied

  16. Bisut

    Bisut Mitglied

    Es gibt bei meinen Kunden keine Besserung! Auch das mit dem setzen von lokalen Rechten, brachte nichts. Die Pfade aus der BAT stimmen aber mit dem PC überein.
    C:\Windows\assembly\GAC_MSIL\Microsoft.Office.Interop.Access\15.0.0.0__71E9BCE111E9429C\Microsoft.Office.Interop.Access.dll
    C:\Windows\assembly\GAC_MSIL\office\15.0.0.0__71E9BCE111E9429C\OFFICE.DLL
    An einem weiteren PC gibt es diese Pfade gar nicht, obwohl an dem PC ebenso eine MS Office 2013 installiert ist.
    Und es sind Original Lizenzen!
    Das einzige was ich an allen PC noch nicht gemacht habe, ist MS Office 2013 komplett zu deinstallieren, MS Tool zur Bereinigungen durchführen. Das geht im Moment leider nicht, weil der Admin dort noch im Urlaub ist.
    Mich wundert es nur, das wenn ich die BAT an dem PC ausführe, wo diese Pfade nicht existieren, das ich danach die Sage dennoch starten kann.
    Ist mein Kunde damit wirklich der einzige in der Sage Welt, der solche Probleme hat?
    Als ich vor einem Jahr die Sage100 in der Version 8.1 damals installiert, gab es keine Probleme, dort waren aber bereits auch schon die MS Office 2013 Produkte installiert gewesen, nur die MS Access 2013 in der Runtime kam von der Sage. Die Probleme finden etwas vor einem Monat an - und jetzt habe ich an allen PC erstmal die Windows Updates für 7 Tage ausgesetzt. Obwohl die letzten Updates Mitte Juni waren. Aber der Fehler mit dem Task Plane kommt jetzt an drei PC täglich. Wird die BAT ausgeführt, geht es.
     

    Anhänge:

    • zeh2.PNG
      zeh2.PNG
      Dateigröße:
      479,7 KB
      Aufrufe:
      8
  17. sebastianbrandt

    sebastianbrandt Neues Mitglied

    Hallo zusammen, ich ärgere mich wie ihr ja auch schon seit Monaten mit dem Fehler rum.Die Batch Datei ist super und macht den Fehler immer Rucki Zucki weg. Aber am nächsten Tag ist der Fehler meistens wieder da was mich genervt hat und zu etlichem Weiteren rumprobieren animiert hat. Ich hab den Fehler bei 2 Usern jetzt dauerhaft weg nach ich deren Profil neu angelegt habe.
     
    m.becker gefällt das.
  18. mandreck

    mandreck Aktives Mitglied

    @sebastianbrandt , ich vermute mal eine Domain oder Arbeitsgruppe, eher Domain. Die Berechtigungen der einzelnen Benutzer sind dann ja eigentlich per GPO geregelt. Sage100 benötigt aber häufig lokale Administrative Rechte (auch wegen diverser Fremd Komponenten die von der Sage 100 benötigt / verwendet werden). Das kannst Du über GPO regeln bzw. wenn es nur wenige User sind den Domain Benutzer auch lokal der Gruppe Administratoren zuweisen. Vorgehensweise wäre in dem Fall erst Benutzer Profil am Client löschen und bevor Du das Benutzer Profil neu erstellst mit einem anderen Administrativen Benutzer den Benutzer der lokalen Gruppe der Administratoren hinzu zu fügen. Danach abmelden und den Benutzer (Neu) anmelden. So erhält der Benutzer alle benötigten Rechte um auch mit der Sage 100 arbeiten zu können. Ich hoffe ich habe mich klar ausgedrückt. Momentan wenig Zeit. :)
     
  19. d.schmitt

    d.schmitt Sage Partner Moderator Mitglieder

    Hallo,

    hat jemand eigentlich mal schon ne Aussage von SAGE bekommen wegen dem Problem, ich habe Kunden da kommt das öfters vor mehrmals im Monat da sich die Berechtigungen auf die 2 genannten Dateien ändern und man diese wieder austauschen / Rechte ändern muss. Danke
     
  20. Bisut

    Bisut Mitglied

    @d.schmitt (Sage lassen wir hier mal außenvor; weiß nicht wie oft ich da schon mit gescheitert bin); letztlich hat bei mir nur eines geholfen. Ich musste die User mit in die Lokale Admin Rechte mit aufnehmen lassen. Anschließend das Tool von @m.becker nutzen, anschließend habe ich die Windows Updates für diese Clients auf 7 Tage aussetzen gestellt. Seit dem hatte ich bei meinem Kunden keine Probleme mehr mit diesen "Mist-Fehler" (Sorry); das hat mich mehr als nur Nerven gekosten, auch super viel unbezahlte Dienstleistungen!
     

Diese Seite empfehlen