Performance Probleme mit SAGE 100

Dieses Thema im Forum "System" wurde erstellt von Techniker, 4. April 2019.

  1. Techniker

    Techniker Neues Mitglied

    Hallo,

    wir haben von SAGE Office Line Evolution 2015 auf SAGE 100 gewechselt, seitdem "laggt" es immer wieder mal. Anfangs dachte ich, dass es an der Speichererweiterung liegt. Nach deaktivieren der Speichererweiterung lief es flüssig, hat aber dann doch wieder angefangen. Hat jemand noch eine Idee? Der SQL Server beansprucht ca. 8GB des Arbeitsspeicher und die VM ist immer zu 90% mit Arbeitsspeicher ausgelastet. Ist die Hardware zu schlecht?

    Kurz ein paar Daten zur Hardware:
    Windows Server 2012 R2 (kein Terminalserver oder Domäne) mit 32GB RAM, und Intel E5 2620 v2.
    SQL Server 2012
    Virtuelle Maschine mit 10GB RAM

    3 Clients (2 davon arbeiten aktiv tagsüber)
    i5 mit 8GB DDR3, SSD und Win 10 Pro

    Gruß
     
  2. mandreck

    mandreck Neues Mitglied

    Auch unsere Kunden beschweren sich teilweise massiv, das alles gefühlt 40% langsamer geht, trotz teilweise guter bis sehr guter Hardware Ausstattung neu. Die neue Optik entschädigt etwas, ist nur nicht durchgehend. Teilweise immer noch die grausamen VBA Masken mit den kleinen Eingabefeldern nicht änderbar etc. Wechsel von Version 6.x auf 8.x.
     
  3. breithecker

    breithecker Administrator Mitglieder

    Hallo,

    das können wir nicht bestätigen. Wenn die Hardware der Empfehlung entspricht, dann liegt es oftmals an Einstellungen. Hierzu gibt es ja Seitens Sage einiges an Dokumentation.

    Gerne kann ich bei Bedarf unsere Unterstützung anbieten.

    Viele Grüße
     
  4. mandreck

    mandreck Neues Mitglied

    Bei der Hardware halten wir uns an die Empfehlungen. Virtualisieren auch selten wenn Sage mit im Spiel ist. Sondern verwenden immer mindestens zwei physikalische Server. Server 2019 Standard, einer als DC /Applikation und einer für SQL 2017. XEON mit min. 3,4 GHz und min. 64GB RAM usw.
    Sage ist zwar ein Teil der Software, die ein Kunde verwendet nur häufig auch andere Software noch zusätzlich. Der Flaschenhals ist immer Sage100 (Access 2013 32bit, max. 4GB abzüglich dem Overhead usw.).
    Da kannst Du die Server noch so fett machen schneller wird es nicht. Aber es entwickelt sich ja langsam auch in die richtige Richtung auch bei Sage100. Auch wen hier häufig noch Altlasten, kompatibilitäten etc. mitgeschleift werden.
    Terminalserver Umgebung eher selten, da werden die Server dann mit min. 192GB RAM ausgestattet für max. 50 Clients.
    Von einer Client / Server Anwendunng, erwarten wir und auch unsere Kunden eher ein flüssigeres Verhalten, da ja nur die Daten übertragen werden und der Rest auf den Clients läuft. Hier verwenden wir min. einen I5 aktuell mit mehr als 3,x GHz und 8GB RAM und 250 GB SSD.

    Ich glaube eher wir müssen uns erst an die Geschwindigkeit gewöhnen. Danke für Dein Angebot.
    Wenn die Anmeldemaske erst nach 20-30 Sekunden erscheint (unnötiges Lizenz Prüfungs geraffel) ist das für eine Client / Server Anwendung schon sehr lange. Mal abgesehen vom Dauerbetrieb der nötig ist um Sage100 ordentlich zu betreiben (Energieoptionen) und von den LiveUpdate Problemen mit der UAC Verwaltung in einer Domäne auch Empfehlung von Sage (auch richtig, nur muss man es nur auch können), AD verwenden, ohne das jeder Domänen-Benutzer gleichzeitig lokale Admin Rechte benötigt usw. ist alles gut. Es gibt schlechtere Lösungen am Markt. :)

    Des wegen bekommt Sage100 auch von uns eine Empfehlung.
    Meine ersten Lösungen von damals noch KHK unter Windows 3.11 schon mit Projektverwaltung / Datanorm / Taglohn / Aufmass etc. lief schneller, warum auch immer. Und da hatten wir bei Kunden schon teilweise mehr als 15 Plätze im Einsatz. Waren immer so zwischen 11-17 Disketten. Müsste ich noch einmal zum Test installieren und die Zeiten vergleichen. :)
     
    breithecker gefällt das.
  5. tfluegel

    tfluegel Neues Mitglied

    Hallo,

    generell kann ich mich Herrn Breithecker nur anschließen: Es gibt einiges an Dokumentation und auch Referenzwerte von Sage. Wenn diese nicht erreicht werden, liegt es wirklich oftmals an Einstellungen.

    Die genannte Zeit von 20-30 Sekunden für eine Anmeldung liegt definitiv außerhalb dieser Referenzwerte. Wenden Sie sich dazu bitte an Ihren Support, damit das geklärt werden kann.

    Viele Grüße
    Thomas Flügel
     
  6. mandreck

    mandreck Neues Mitglied

    Nicht das wir uns falsch verstehen. Um sich durch die 3-4 Masken durchzuklickern. Wenn mit mehreren Mandaten und mehreren Datenbanken gearbeitet wird um dann wirklich arbeiten zu können sind eben die 20-30 Sekunden. Bei einem Mandant und einer DB ist der Wert kleiner. Kommt noch ein umfangreiches Dashboard hinzu, können das auch mehr als 30 Sekunden gerne mal sein. Und immer im Kopf, in einer Domaine, als Client/Server Anwendung, nicht Fileserver und lokaler DB etc.

    Und nicht zu vergessen, der Sage Preloader muss vollständig gestartet sein. Klickt ein Benutzer vor dem vollständigen Laden des Preloaders, auf Sage starten, hat er gleich wieder ein Lizenz- Anmeldeproblem. Und der brauch eben von allen Diensten auf dem Client am längsten. Der startet in der Regel erst am Ende, als letzter. Das Böse Windows wieder oder doch Sage100 welches so etwas benötigt um den Arbeitsspeicher permanet zu füllen, damit es überhaubt gescheit läuft? Auch nach dem beenden von Sage100 am Client, bleibt ja der Preloader geladen (persistent im Speicher) um dem Kunden ein schnelleres starten der Anwendung vorzugauckeln.
    Den wenn der jedesmal entladen werde würde um den Client auch für andere Programme den Speicher wieder vollständig zu Verfügung zu stellen, reichen dann 30 Sekunden schon mal gar nicht mehr.
     
    Zuletzt bearbeitet: 16. Juni 2019 um 05:00 Uhr

Diese Seite empfehlen